import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (.+)(\\n( [^ ].+\\n)+)";
final String string = " ARTHUR \n"
+ " Yeah. I mean, that's just--\n\n"
+ " SOCIAL WORKER\n"
+ " Does my reading it upset you?\n\n"
+ "He leans in.\n\n"
+ " ARTHUR\n"
+ " No. I just,-- some of its \n"
+ " personal. You knowome ?\n"
+ " SOCIAL WORKER\n"
+ " I understand. I just want to make \n"
+ " sure you're keeping up with it.\n"
+ "She slides his journal back to him. He holds it in his lap.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}