$re = '/ (.+)(\n( [^ ].+\n)+)/';
$str = ' ARTHUR
Yeah. I mean, that\'s just--
SOCIAL WORKER
Does my reading it upset you?
He leans in.
ARTHUR
No. I just,-- some of its
personal. You knowome ?
SOCIAL WORKER
I understand. I just want to make
sure you\'re keeping up with it.
She slides his journal back to him. He holds it in his lap.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);