import re
regex = re.compile(r" (.+)(\n( [^ ].+\n)+)")
test_str = (" ARTHUR \n"
" Yeah. I mean, that's just--\n\n"
" SOCIAL WORKER\n"
" Does my reading it upset you?\n\n"
"He leans in.\n\n"
" ARTHUR\n"
" No. I just,-- some of its \n"
" personal. You knowome ?\n"
" SOCIAL WORKER\n"
" I understand. I just want to make \n"
" sure you're keeping up with it.\n"
"She slides his journal back to him. He holds it in his lap.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")