#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)OpenTag\s*([^]*?)\s*CloseTag"
Local $sString = "OpenTag" & @CRLF & _
" The Content I want 1" & @CRLF & _
"CloseTag" & @CRLF & _
"" & @CRLF & _
"OpenTagCloseTag" & @CRLF & _
"" & @CRLF & _
"OpenTag The Content I want 2 CloseTag" & @CRLF & _
"" & @CRLF & _
"OpenTag" & @CRLF & _
" The Content I want" & @CRLF & _
" spans 2 lines" & @CRLF & _
"CloseTag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")