use strict;
my $str = 'OpenTag
The Content I want 1
CloseTag
OpenTagCloseTag
OpenTag The Content I want 2 CloseTag
OpenTag
The Content I want
spans 2 lines
CloseTag';
my $regex = qr/OpenTag\s*([^]*?)\s*CloseTag/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}