// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)OpenTag\s*([^]*?)\s*CloseTag").unwrap();
let string = "OpenTag
The Content I want 1
CloseTag
OpenTagCloseTag
OpenTag The Content I want 2 CloseTag
OpenTag
The Content I want
spans 2 lines
CloseTag";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}