$re = '/OpenTag\s*([^]*?)\s*CloseTag/m';
$str = 'OpenTag
The Content I want 1
CloseTag
OpenTagCloseTag
OpenTag The Content I want 2 CloseTag
OpenTag
The Content I want
spans 2 lines
CloseTag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);