import re
regex = re.compile(r"OpenTag\s*([^]*?)\s*CloseTag", flags=re.MULTILINE)
test_str = ("OpenTag\n"
" The Content I want 1\n"
"CloseTag\n\n"
"OpenTagCloseTag\n\n"
"OpenTag The Content I want 2 CloseTag\n\n"
"OpenTag\n"
" The Content I want\n"
" spans 2 lines\n"
"CloseTag")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")