const regex = /OpenTag\s*([^]*?)\s*CloseTag/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('OpenTag\\s*([^]*?)\\s*CloseTag', 'gm')
const str = `OpenTag
The Content I want 1
CloseTag
OpenTagCloseTag
OpenTag The Content I want 2 CloseTag
OpenTag
The Content I want
spans 2 lines
CloseTag`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}