using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\)|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|\{((?:[A-Za-z])+)\})(?:(\+|\-|\*|\/)(?:(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\))|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|(?:\{((?:[A-Za-z])+)\})))*";
string input = @"ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})
SUM({AbcdefgF})+SUM({AbcdefgF})
{AbcdefgF}+{AbcdefgF}-{AbcdefgF}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}