import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(SUM|AGV|ABS)\\(\\{((?:[A-Za-z])+)\\}\\)|(?:(SUM|AGV|ABS)\\(\\{((?:[A-Za-z])+)\\}\\,\\{((?:[A-Za-z])+)\\}\\))|\\{((?:[A-Za-z])+)\\})(?:(\\+|\\-|\\*|\\/)(?:(?:(SUM|AGV|ABS)\\(\\{((?:[A-Za-z])+)\\}\\))|(?:(SUM|AGV|ABS)\\(\\{((?:[A-Za-z])+)\\}\\,\\{((?:[A-Za-z])+)\\}\\))|(?:\\{((?:[A-Za-z])+)\\})))*";
final String string = "ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})\n"
+ "SUM({AbcdefgF})+SUM({AbcdefgF})\n"
+ "{AbcdefgF}+{AbcdefgF}-{AbcdefgF}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}