package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\)|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|\{((?:[A-Za-z])+)\})(?:(\+|\-|\*|\/)(?:(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\))|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|(?:\{((?:[A-Za-z])+)\})))*`)
var str = `ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})
SUM({AbcdefgF})+SUM({AbcdefgF})
{AbcdefgF}+{AbcdefgF}-{AbcdefgF}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}