import Foundation
let pattern = #"(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\)|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|\{((?:[A-Za-z])+)\})(?:(\+|\-|\*|\/)(?:(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\))|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|(?:\{((?:[A-Za-z])+)\})))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})
SUM({AbcdefgF})+SUM({AbcdefgF})
{AbcdefgF}+{AbcdefgF}-{AbcdefgF}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)