// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\)|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|\{((?:[A-Za-z])+)\})(?:(\+|\-|\*|\/)(?:(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\))|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|(?:\{((?:[A-Za-z])+)\})))*").unwrap();
let string = "ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})
SUM({AbcdefgF})+SUM({AbcdefgF})
{AbcdefgF}+{AbcdefgF}-{AbcdefgF}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}