#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[0-9]{1,4}$|TOTAL"
Local $sString = "960" & @CRLF & _
"2448" & @CRLF & _
"TOTAL" & @CRLF & _
"total" & @CRLF & _
"toTAL" & @CRLF & _
"TOTal" & @CRLF & _
"total" & @CRLF & _
"4420" & @CRLF & _
"9000" & @CRLF & _
"texto" & @CRLF & _
"blabla" & @CRLF & _
"12345" & @CRLF & _
" " & @CRLF & _
"asd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")