import re
regex = re.compile(r"^[0-9]{1,4}$|TOTAL", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("960\n"
"2448\n"
"TOTAL\n"
"total\n"
"toTAL\n"
"TOTal\n"
"total\n"
"4420\n"
"9000\n"
"texto\n"
"blabla\n"
"12345\n"
" \n"
"asd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")