// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[0-9]{1,4}$|TOTAL").unwrap();
let string = "960
2448
TOTAL
total
toTAL
TOTal
total
4420
9000
texto
blabla
12345
asd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}