import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{1,4}$|TOTAL";
final String string = "960\n"
+ "2448\n"
+ "TOTAL\n"
+ "total\n"
+ "toTAL\n"
+ "TOTal\n"
+ "total\n"
+ "4420\n"
+ "9000\n"
+ "texto\n"
+ "blabla\n"
+ "12345\n"
+ " \n"
+ "asd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}