const regex = /^[0-9]{1,4}$|TOTAL/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,4}$|TOTAL', 'img')
const str = `960
2448
TOTAL
total
toTAL
TOTal
total
4420
9000
texto
blabla
12345
asd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}