$re = '/^[0-9]{1,4}$|TOTAL/im';
$str = '960
2448
TOTAL
total
toTAL
TOTal
total
4420
9000
texto
blabla
12345
asd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);