# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*([^\w\s])\s*/$1/gm;t' <<< "Some - text +=@!#$#$^%* here . "