use strict;
my $str = 'Some - text +=@!#$#$^%* here . ';
my $regex = qr/\s*([^\w\s])\s*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";