re = /\s*([^\w\s])\s*/m
str = 'Some - text +=@!#$#$^%* here . '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result