$re = '/\s*([^\w\s])\s*/m';
$str = 'Some - text +=@!#$#$^%* here . ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;