package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([^\w\s])\s*`)
var str = `Some - text +=@!#$#$^%* here . `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}