using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^""]+""[^""]+"")([^""]+)""([^""]+)""";
string substitution = @"$1$2$3";
string input = @"Production App ""Old"": Service Name: "".ProdApp - Slave1""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}