$re = '/([^"]+"[^"]+")([^"]+)"([^"]+)"/m';
$str = 'Production App "Old": Service Name: ".ProdApp - Slave1"';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;