#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\=(?=([^\"']*[\"'][^\"']*[\"'])*[^\"']*$)"
Local $sString = "a="one", b=10, c=["1",2,3], d="a=1", e="b='two'", f='q="hello"', g={"a":1}, h = x + "hello", i = {q:[1,'c']}, h="[1,2,3]", j = '"hello, there"', k = a~b + c" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")