use strict;
my $str = 'a="one", b=10, c=["1",2,3], d="a=1", e="b=\'two\'", f=\'q="hello"\', g={"a":1}, h = x + "hello", i = {q:[1,\'c\']}, h="[1,2,3]", j = \'"hello, there"\', k = a~b + c
https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/';
my $regex = qr/\=(?=([^\"']*[\"'][^\"']*[\"'])*[^\"']*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}