const regex = /\=(?=([^\"']*[\"'][^\"']*[\"'])*[^\"']*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\=(?=([^\\"\']*[\\"\'][^\\"\']*[\\"\'])*[^\\"\']*$)', 'gm')
const str = `a="one", b=10, c=["1",2,3], d="a=1", e="b='two'", f='q="hello"', g={"a":1}, h = x + "hello", i = {q:[1,'c']}, h="[1,2,3]", j = '"hello, there"', k = a~b + c
https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}