import Foundation
let pattern = #"\=(?=([^\"']*[\"'][^\"']*[\"'])*[^\"']*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a="one", b=10, c=["1",2,3], d="a=1", e="b='two'", f='q="hello"', g={"a":1}, h = x + "hello", i = {q:[1,'c']}, h="[1,2,3]", j = '"hello, there"', k = a~b + c
https://stackabuse.com/regex-splitting-by-character-unless-in-quotes/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)