# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:!!|test)\h.*(*SKIP)(*F)|(\bStreet|\G(?!^)[\d-]*,)(?=\d)/$1UK\//gm;t' <<< "Street1-2,4,6,8-10
!! Street4/31/2
test Street4
abc-3,4,5,6
1,2,3"