re = /^(?:!!|test)\h.*(*SKIP)(*F)|(\bStreet|\G(?!^)[\d-]*,)(?=\d)/m
str = 'Street1-2,4,6,8-10
!! Street4/31/2
test Street4
abc-3,4,5,6
1,2,3'
subst = '$1UK/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result