use strict;
my $str = 'Street1-2,4,6,8-10
!! Street4/31/2
test Street4
abc-3,4,5,6
1,2,3';
my $regex = qr/^(?:!!|test)\h.*(*SKIP)(*F)|(\bStreet|\G(?!^)[\d-]*,)(?=\d)/mp;
my $subst = '$1UK/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";