import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:!!|test)\\h.*(*SKIP)(*F)|(\\bStreet|\\G(?!^)[\\d-]*,)(?=\\d)";
final String string = "Street1-2,4,6,8-10\n"
+ "!! Street4/31/2\n"
+ "test Street4\n"
+ "abc-3,4,5,6\n"
+ "1,2,3";
final String subst = "$1UK/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}