import re
regex = re.compile(r"^(?:!!|test)\h.*(*SKIP)(*F)|(\bStreet|\G(?!^)[\d-]*,)(?=\d)", flags=re.MULTILINE)
test_str = ("Street1-2,4,6,8-10\n"
"!! Street4/31/2\n"
"test Street4\n"
"abc-3,4,5,6\n"
"1,2,3")
subst = "$1UK/"
result = regex.sub(subst, test_str)
if result:
print(result)