using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:!!|test)\h.*(*SKIP)(*F)|(\bStreet|\G(?!^)[\d-]*,)(?=\d)";
string substitution = @"$1UK/";
string input = @"Street1-2,4,6,8-10
!! Street4/31/2
test Street4
abc-3,4,5,6
1,2,3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}