package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([. ])(com|ltd|llc|corp|stores)`)
var str = `Amazon
Amazon.com
Amazon.llc
Amazon.ltd
Amazon corp
Amazon stores`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}