import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([. ])(com|ltd|llc|corp|stores)";
final String string = "Amazon\n"
+ "Amazon.com\n"
+ "Amazon.llc\n"
+ "Amazon.ltd\n"
+ "Amazon corp\n"
+ "Amazon stores";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}