re = /([. ])(com|ltd|llc|corp|stores)/m
str = 'Amazon
Amazon.com
Amazon.llc
Amazon.ltd
Amazon corp
Amazon stores'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end