$re = '/([. ])(com|ltd|llc|corp|stores)/m';
$str = 'Amazon
Amazon.com
Amazon.llc
Amazon.ltd
Amazon corp
Amazon stores';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);