package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \d{1,2}[д]\d{1,2}[ч]\d{1,2}[м]\d{1,2}[с]|\d{1,2}[м]\d{1,2}[с]`)
var str = ` 25д10ч3м10с
15м30с`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}