re = / \d{1,2}[д]\d{1,2}[ч]\d{1,2}[м]\d{1,2}[с]|\d{1,2}[м]\d{1,2}[с]/
str = ' 25д10ч3м10с
15м30с'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end