import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \\d{1,2}[д]\\d{1,2}[ч]\\d{1,2}[м]\\d{1,2}[с]|\\d{1,2}[м]\\d{1,2}[с]";
final String string = " 25д10ч3м10с\n"
+ " 15м30с";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}