$re = '/ \d{1,2}[д]\d{1,2}[ч]\d{1,2}[м]\d{1,2}[с]|\d{1,2}[м]\d{1,2}[с]/';
$str = ' 25д10ч3м10с
15м30с';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);