const regex = / \d{1,2}[д]\d{1,2}[ч]\d{1,2}[м]\d{1,2}[с]|\d{1,2}[м]\d{1,2}[с]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' \\d{1,2}[д]\\d{1,2}[ч]\\d{1,2}[м]\\d{1,2}[с]|\\d{1,2}[м]\\d{1,2}[с]', 'g')
const str = ` 25д10ч3м10с
15м30с`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}