# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)[ ]([\*&]+)([a-zA-Z])/$1$2 $3/gm;t' <<< "const char *name,;
char **argv
const SomeType &some_value
value * other"