#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)[ ]([\*&]+)([a-zA-Z])"
Local $sString = "const char *name,;" & @CRLF & _
"char **argv" & @CRLF & _
"const SomeType &some_value" & @CRLF & _
"value * other"
Local $sSubst = "$1$2 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)