$re = '/(\w+)[ ]([\*&]+)([a-zA-Z])/m';
$str = 'const char *name,;
char **argv
const SomeType &some_value
value * other';
$subst = "$1$2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;