package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)[ ]([\*&]+)([a-zA-Z])`)
var str = `const char *name,;
char **argv
const SomeType &some_value
value * other`
var substitution = "$1$2 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}